Liberty Broadband Outagr

Incident Report for Liberty Broadband

Resolved

All traffic has stayed stable over the last 24hrs so we will resolve this status page, however we will continue to communicate with our upstream provider that had the issue and work with them to get it resolved so we can have both traffic routes open for future use.
Posted Aug 28, 2026 - 11:08 MDT

Monitoring

Our network engineer was able to identify the issue and implement a fix. The issue was due to one of our upstream provider's having an issue, our network engineer re-routed to one of our other upstream providers to get connections back online. We will monitor this very closely over the next 24 hrs and we will continue to work with the upstream provider that had an issue to get it fixed on their end.
Posted Aug 27, 2026 - 09:28 MDT

Update

We are currently investigating an outage that is affecting some of our towers and repeaters.
Posted Aug 27, 2026 - 09:01 MDT

Investigating

We are aware of an outage affecting our network. We are working on identifying the issue and getting it corrected.
Posted Aug 27, 2026 - 08:44 MDT
This incident affected: Huntsville Square Tower (Hunt-1-30, Hunt-2-30, Hunt-3-30, Hunt-4-30, Hunt-5-30, Hunt-7-30, Hunt-8-30, Hunt-10-30, Hunt-11-30, Hunt-12-30, Hunt-13-30, Hunt-14-30, Hunt-15-30), Monastery Tower (Monastery-1-90, Monastery-2-90), North Fork Tower (NorthTower-1-60, NorthTower-2-60, NorthTower-3-60), PF Tower (PF-Tower-1, PF-Tower-2), Snow Basin Tower (SnowBasin-1-90, SnowBasin-2-90, SnowBasin-3-90), Wolf Creek TV Tower (TV-Translator-1-120, TVTower-1-30, TVTower-2-30, TVTower-3-30, TVTower-4-30, TVTower-5-30, TVTower-6-30, TVTower-7-30, TVTower-8-30, TV Tower 0- Wave, TV-Tower 9-90), Falcon Tower (Falcon-1, Falcon-2, Falcon-3, Falcon-4), and Undercity Tower, Ironforge Tower, Goldshire Omni.