Liberty Broadband Falcon Tower Only Outage

Incident Report for Liberty Broadband

Resolved

The tower was stable all night so we will move forward with closing out this status page. If you are experiencing issues still please let us know.
Posted Jan 28, 2026 - 09:39 MST

Monitoring

Our tech was able to locate the issue once on site and we now have the tower online. The tech found that at some point today the tower had swapped from main power grid to our back up batteries and had been running off back up batteries until they drained. He was able to get the tower back on the main power grid and we will keep a close eye on the tower throughout the night.
Posted Jan 27, 2026 - 17:48 MST

Investigating

We are aware of an outage issue that our Falcon Tower has been having this afternoon, we have a tech headed to get on site for the tower to assess the situation. Once we have a better update we will let you know.
Posted Jan 27, 2026 - 16:36 MST
This incident affected: Falcon Tower (Falcon-1, Falcon-2, Falcon-3, Falcon-4).