The sector has not had any issues since being replaced yesterday. We will move forward with closing out this status page.
Posted Feb 18, 2026 - 09:47 MST
Monitoring
We now have Sector 9-90 up and working. One of the clips on the sector broke during the wind storm and we have replaced it with a brand new sector. We will monitor the sector closely for the next 24hrs.
Posted Feb 17, 2026 - 12:49 MST
Investigating
We are aware that one of our sectors on TV Tower went down late last night, despite several efforts remotely to get the sector back online we need to get a tech on site to get the sector back up and working. We have a tech scheduled to be there first thing this morning, we are also battling against the storm that has moved in so we will work as quickly and as safely as possible to get this sector back online. This outage is only affecting those that are on TV Tower Sector 9, not all of TV Tower is down.
If you are unsure if this outage is affecting you specifically please feel free to text us at 866-780-8036
Posted Feb 17, 2026 - 07:26 MST
This incident affected: Wolf Creek TV Tower (TV-Tower 9-90).