We will be closing out this status page as the tower stayed online and stable for the last 24/hrs.
Posted May 27, 2026 - 15:00 MDT
Monitoring
The fix has been completed and the tower is back online and all dishes have connected. We will monitor the tower for the next 24hrs before we close this status page.
Posted May 26, 2026 - 16:31 MDT
Identified
Our tech has arrived on site and found that while a crew was digging holes for fencing they hit the conduit with the line for the tower. They are already in the process of fixing the line and anticipate the fix being done in the next 15-20mins. Will update here once the tower is back online.
Posted May 26, 2026 - 16:13 MDT
Investigating
We are aware of an outage affecting our customers on the IronForge Tower that is located in the Mtn. Green area. We have dispatched a tech to the area and once we have more information we will update this page.