Liberty Broadband Morgan Only outage

Incident Report for Liberty Broadband

Resolved

This incident has been resolved.
Posted Apr 13, 2026 - 09:02 MDT

Monitoring

The internet is back online for those in the Morgan/Mtn. Green area. We had a router get hung up that needed to be rebooted. We will monitor it closely for the next 24 hrs to ensure it is running smoothly.
Posted Apr 09, 2026 - 16:35 MDT

Update

We are continuing to investigate this issue.
Posted Apr 09, 2026 - 16:26 MDT

Investigating

We are currently experiencing an outage in the Morgan/Mtn. Green area. We are unable to access the equipment remotely so we have a tech dispatched. Once we know more we will update you here.
Posted Apr 09, 2026 - 16:25 MDT
This incident affected: Undercity Tower, Thunderbluff Tower, Orgrimmar Tower, Ironforge Tower, Brill Tower, Silvermoon Tower, Splintertree Tower, Goldshire Omni, and Sun Rock Tower.